[Solved (debug mode)] built with qPCL, but MLS is 30x slower

All about Windows versions
dcaron05
Posts: 2
Joined: Wed Sep 14, 2016 7:52 pm

[Solved (debug mode)] built with qPCL, but MLS is 30x slower

Postby dcaron05 » Wed Sep 14, 2016 8:10 pm

Hi,

I successfully built the trunk 2.8 version with the qPcl plugin (the only activated plugin) on windows 7 x64, vs2013.

I used the "PCL 1.7.2 All-in-one Installer MSVC2013 x64" from http://unanancyowen.com/?p=712 and all the dependencies inside (eigen, boost, flann, vtk)

Everything works fine, but when I try to use the MLS smoothing command, it takes 5 minutes for the same command that takes 10 seconds to execute using the official build.

I also tried PCL 1.8 All-in-one with the same result.

Any idea is appreciated.

Thanks
Last edited by dcaron05 on Thu Sep 15, 2016 11:07 am, edited 1 time in total.

daniel
Site Admin
Posts: 3375
Joined: Wed Oct 13, 2010 7:34 am
Location: Grenoble, France
Contact:

Re: built with qPCL, but MLS is 30x slower

Postby daniel » Wed Sep 14, 2016 8:52 pm

Be sure to run CC in release mode (and not the default 'debug' mode which is great for debugging but awfully slow).
Daniel, CloudCompare admin

dcaron05
Posts: 2
Joined: Wed Sep 14, 2016 7:52 pm

Re: built with qPCL, but MLS is 30x slower

Postby dcaron05 » Thu Sep 15, 2016 11:06 am

Yep, that's it exactly. I'm still new to c++ compilation. Thanks a lot.


Return to “Windows related topics”

Who is online

Users browsing this forum: No registered users and 2 guests